Erfahren Sie in diesem Artikel,
- welche Voraussetzungen für diese Korrektur gegeben sein müssen und
- wie Sie diese Korrektur anwenden können.
1. Einführung
In der Applikation $PRODUCT_NAME_WORKFLOW steht die Korrektur Objekte auf Ebene legen zur Verfügung. Das Ziel dieser Korrektur ist es, alle durch eine Prüfung gefundenen Objekte einer bereits bestehenden Ebene zuzuweisen bzw. auf eine neue Ebene zu legen.
2. Allgemeines
Die Korrektur Objekt auf Ebene legen kann verwendet werden, um einzelne Objekte – Vektoren, Texte oder Bilder – auf eine bestehende oder neue Ebene zu legen. Damit können beispielsweise eine technische Linie, ein Weißkanal, eine Prägefolie usw. auf eine eigene Ebene gelegt werden.
Die Korrektur finden Sie im Reiter Datenkorrektur eines Artikels, Auftrags bzw. Produktionsauftrags durch:
- Eingabe des Namens der Korrektur im Bereich Filter,
- Aktivieren der Option Objekt im Bereich Kategorie,
- Aktivieren der Option Erzeugen im Bereich Aktion sowie
- Aktivieren der Option Sonderfarbe im Bereich Eigenschaft.
3. Beschreibung
Mit dieser Korrektur können alle bei der Prüfung gefundenen Objekte auf bereits bestehende oder neu angelegte Ebenen verschoben werden.
3.1. Voraussetzungen und Funktionsweise
Damit die Korrektur wie vorgesehen funktioniert, müssen folgende Voraussetzungen erfüllt sein:
- In der Datei können bereits Ebenen vorhanden sein; dies ist jedoch nicht zwingend erforderlich.
- Die Prüfung findet Bilder, Texte, Vektoren und Sonderfarben.
Die Korrektur Objekte auf Ebene legen besteht aus fünf einzelnen Korrekturen, die in einem gemeinsamen Dialog zusammengefasst sind. Sie können einzelne ausgewählte Korrekturen für bestimmte Objekttypen zu aktivieren und dadurch gezielt ausführen.
Abbildung 1: Der Dialog der Korrektur Objekte auf Ebene legen mit aktivierter Korrektur Ebene hinzufügen
Nachfolgend werden die einzelnen Korrekturen detailliert beschrieben:
3.1.1. Ebene hinzufügen
Standardmäßig ist diese Korrektur aktiviert, was durch die aktivierte Checkbox [1] angezeigt wird. Mit dieser Korrektur wird eine neue Ebene mit einem selbst ausgewählten Ebenennamen hinzugefügt.
Um eine neue Ebene hinzuzufügen oder eine bestehende Ebene auszuwählen, steht folgende Option zur Verfügung:
- Ebenenname [6] – geben Sie hier den gewünschten Ebenennamen ein. Ist die Ebene bereits im Dokument vorhanden, werden die gefundenen Objekte auf diese Ebene verschoben. Existiert der eingegebene Ebenenname noch nicht, wird eine neue Ebene mit dem Ebenennamen angelegt und die gefundenen Objekte darauf verschoben. Wählen Sie für den Variablen Inhalt [7] den gewünschten Platzhalter – Datenbankfeld bzw. Benutzerdefiniertes Feld – aus, woraus der Wert für den Ebenennamen entnommen werden soll.
Korrektur Ebene hinzufügen notwendig!
Damit alle Korrekturen wie erwartet funktionieren, muss die Korrektur Ebene hinzufügen aktiviert sein. Geben Sie hier den Namen der bestehenden Ebenen bzw. den Namen der zu erstellen Ebene ein und aktivieren Sie zusätzlich alle Korrekturen mit Objekten, die auf diese Ebene verschoben werden sollen.
Abbildung 2: Der Dialog der Korrektur Objekte auf Ebene legen mit aktivierter Korrektur Ebene hinzufügen
3.1.2. Text auf Ebene verschieben
Durch Aktivieren der Checkbox [2] (Abbildung 1) wird die Korrektur Text auf Ebene verschieben aktiviert. Diese Korrektur verschiebt alle Textobjekte der Datei auf die neue oder bereits bestehende Ebene. Geben Sie dazu zuvor den Namen der jeweiligen Ebene [8] in der Korrektur Ebene hinzufügen ein.
Es können keine weiteren Optionen gewählt werden.
Abbildung 3: Der Dialog der Korrektur Objekte auf Ebene legen mit den aktivierten Korrekturen Ebene hinzufügen und Text auf Ebene verschieben
3.1.3. Vektoren auf Ebene verschieben
Durch Aktivieren der Checkbox [3] (Abbildung 1) wird die Korrektur Vektoren auf Ebene verschieben aktiviert. Diese Korrektur verschiebt alle Vektorobjekte der Datei auf die neue oder bereits bestehende Ebene. Geben Sie dazu zuvor den Namen der jeweiligen Ebene [9] in der Korrektur Ebene hinzufügen ein.
Es können keine weiteren Optionen gewählt werden.
Abbildung 4: Der Dialog der Korrektur Objekte auf Ebene legen mit den aktivierten Korrekturen Ebene hinzufügen und Vektoren auf Ebene verschieben
3.1.4. Bilder auf Ebene verschieben
Durch Aktivieren der Checkbox [4] (Abbildung 1) wird die Korrektur Bilder auf Ebene verschieben aktiviert. Diese Korrektur verschiebt alle Bilder der Datei auf die neue oder bereits bestehende Ebene. Geben Sie dazu zuvor den Namen der jeweiligen Ebene [10] in der Korrektur Ebene hinzufügen ein.
Es können keine weiteren Optionen gewählt werden.
Abbildung 5: Der Dialog der Korrektur Objekte auf Ebene legen, mit den aktivierten Korrekturen Ebene hinzufügen und Bilder auf Ebene verschieben
3.1.5. Objekte der gewählten Sonderfarbe auf Ebene verschieben
Durch Aktivieren der Checkbox [5] (Abbildung 1) wird die Korrektur Objekte der gewählten Sonderfarbe auf Ebene verschieben aktiviert. Diese Korrektur verschiebt alle ausgewählten Sonderfarbobjekte der Datei auf die neue oder bereits bestehende Ebene. Geben Sie dazu zuvor den Namen der jeweiligen Ebene [11] in der Korrektur Ebene hinzufügen ein.
Um Sonderfarbobjekte auf eine Ebene zu verschieben, steht folgende Option zur Verfügung:
- Sonderfarbe [12] – wählen Sie im Auswahlmenü jene Sonderfarbe aus, deren Objekte auf die ausgewählte Ebene verschoben werden sollen.
Abbildung 6: Der Dialog der Korrektur Objekte auf Ebene legen mit den aktivierten Korrekturen Ebene hinzufügen und Objekte der gewählten Sonderfarbe auf Ebene verschieben
3.2. Vorher/Nachher
Zum Experimentieren mit dieser Funktion können Sie auf die Beispieldatei »Sample_Add Objects to Layers.pdf« zurückgreifen. Die Datei besteht aus Vektoren, einer Textzeile, einem Bild sowie einer Schneidelinie, die auf dem Endformatrahmen sitzt. Das Haus auf der linken Seite ist ein Bild. Am unteren Teil des Motivs befindet sich eine Textzeile. Das restliche Motiv besteht aus Vektoren. Alle Objekte der Datei befinden sich auf Ebene 2.
Nach Anwendung der Korrektur entsteht die Datei »Sample_Add Objects to Layers_End.pdf«. Die Textzeile der Datei wurde auf die neu erstellte Ebene »Text« verschoben. Das Bild der Datei wurde auf die neu erstellte Ebene »Image« verschoben. Alle Vektoren sowie die Schneidelinie liegen weiterhin auf der Ebene 2.
Korrektur muss mehrfach ausgeführt werden
Um das gewünschte Ergebnis zu erzielen, muss die Korrektur entweder dreimal ausgeführt oder dreimal mit jeweils unterschiedlichen Werten in eine Korrekturkette eingebunden werden.
Abbildung 7: Links: Originaldatei; Rechts: Überarbeitete Datei, in der zwei neue Ebenen erstellt wurden
Artikel Update: $PRODUCT_NAME_WORKFLOW 2.3.0 – 09/2026






